VIB

Conflicting VIBs upgrading from VMWare vSphere 5.1 to vSphere 5.5 U1

I had a DL360 Gen8 server running VMWare vSphere 5.1 which was installed using the HP custom image. When trying to upgrade this server to vSphere 5.5u1 using the new HP ISO, the upgrade failed with the following error message:

The upgrade contains the following set of conflicting VIBs:
Broadcom_bootbank_net-bnx2_2.2.5d.v55.2-1OEM.550.0.0.1331820
Broadcom_bootbank_net-bnx2_2.2.5d.v55.2-1OEM.550.0.0.1331820
 
Remove the conflicting VIBs or use Image Builder to create a custom upgrade ISO image that contains the newer versions of the conflicting VIBs, and try to upgrade again.

It seems that the version of the broadcom drivers in vSphere 5.5u1 are older than those included in v5.5 and v5.1u2.

As a workaround, upgrade the host to v5.5, then downgrade the broadcom driver to 2.2.5d, and upgrade the host to v5.5u1 again. It might not be the easiest solution if you have many hosts to upgrade but in my case there were only two so this was the fastest.

  1. Download http://vibsdepot.hp.com/hpq/jun2014/esxi-550-devicedrivers/BCM-NetXtremeII-4.0-1796156.zip and extract the BCM-NetXtremeII-4.0-offline_bundle-1796156.zip
  2. Copy this file to /tmp on the ESXi host
  3. Run esxcli software vib install --depot=/tmp/BCM-NetXtremeII-4.0-offline_bundle-1796156.zip

After a reboot, upgrading to 5.5u1 should now work as expected.

Blog Category:

Subscribe to RSS - VIB